动力节点旗下在线教育品牌  |  咨询热线:400-8080-105 学Java全栈,上蛙课网

启动springcloud eureka报错。

代码小兵1554955025

2019.11.25

No qualifying bean of type 'javax.servlet.Filter' available: expected at least 1 bean which qualifies as autowire candidate. Dependency annotations: {@org.springframework.beans.factory.annotation.Qualifier(value=httpTraceFilter)}

添加回答

回答(1)

军哥

老师参与

你参考蛙课网视频上的操作的吗?蛙课视频Spring Cloud版本是Spring Cloud Finchley,所对应的Spring Boot版本是2.0.3,这里需要注意一个坑就是Spring Boot 的版本要和 Spring Cloud 的版本相对应,如果版本不对应,会遇到很多报错的情况,他们的匹配关系是:

Spring Cloud Hoxton -->    Spring Boot 2.2.x
Spring Cloud Greenwich -->    Spring Boot 2.1.x
Spring Cloud Finchley -->    Spring Boot 2.0.x
Spring Cloud Edgware -->    Spring Boot 1.5.x

时间:11-26 11:01 查看回复 (0) 回复 0 0 举报

回复