动力节点旗下在线教育品牌  |  咨询热线:400-8080-105 学Java全栈,上蛙课网

学习springcloud时遇到的 不知道 怎么解决 老师使用的是1.x的版本,我用的2.2.x 以下是依赖和报错 有解决的办法嘛

代码小兵1550746538

2020.02.22
<dependencies>
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-web</artifactId>
    </dependency>

    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-test</artifactId>

    </dependency>

    <!--Spring Cloudeureka-server起步依赖-->
    <dependency>
        <groupId>org.springframework.cloud</groupId>
        <artifactId>spring-cloud-starter-netflix-eureka-client</artifactId>
    </dependency>

    <!--Spring Cloud 熔断器起步依赖 -->
    <dependency>
        <groupId>org.springframework.cloud</groupId>
        <artifactId>spring-cloud-starter-hystrix</artifactId>
        <version>1.4.5.RELEASE</version>
    </dependency>

    <!--spring boot的服务监控依赖 -->
    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-actuator</artifactId>
    </dependency>
</dependencies>

 

--------------------------------------------------------------------------------------------------------------------------

报错内容

添加回答

回答(1)

军哥

老师参与

Finchley

Spring Boot 2.0.x


视频里面Spring Cloud是F版,Spring Boot是 2.0.3版本,按照这个版本来操作是匹配的;

如果版本不一样,一个会有版本匹配的问题,另一个是有一些小的区别,可以按照视频的版本来操作;

时间:02-23 11:02 查看回复 (1) 回复 1 0 举报

代码小兵1550746538

调整为H版和2.2.x了  之间使用的F版的 调整之后兼容了 谢谢军哥 !

时间:02-23 13:31 回复 举报

回复