动力节点旗下在线教育品牌  |  咨询热线:400-8080-105 学Java全栈,上蛙课网

Spring boot项目必须使用JDK8以上版本吗?

斩天及

2019.03.14

我用的JDK7,pom.xml也配置了

启动报错:

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/springframework/boot/SpringApplication : Unsupported major.minor version 52.0

 

百度查的答案非让用JDK8,如果我就想用JDK7,不行么?

添加回答

回答(1)

军哥

已采纳

SpringBoot 2.x版本需要至少JDK8,如果是SpringBoot1.x版本,可以兼容JDK6.

时间:03-14 17:13 查看回复 (1) 回复 2 0 举报

斩天及

的确是自己配置的问题。之前项目的pom.xml都是公司给配好了。

自己想写个,就各种版本兼容报错。

时间:04-12 11:13 回复 举报

回复